Filter |
Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons

System Object
Autodesk.Revit.DB FilterRule
Autodesk.Revit.DB FilterValueRule
Autodesk.Revit.DB FilterNumericValueRule
Autodesk.Revit.DB FilterDoubleRule
Autodesk.Revit.DB FilterElementIdRule
Autodesk.Revit.DB FilterGlobalParameterAssociationRule
Autodesk.Revit.DB FilterIntegerRule
Autodesk.Revit.DB FilterRule
Autodesk.Revit.DB FilterValueRule
Autodesk.Revit.DB FilterNumericValueRule
Autodesk.Revit.DB FilterDoubleRule
Autodesk.Revit.DB FilterElementIdRule
Autodesk.Revit.DB FilterGlobalParameterAssociationRule
Autodesk.Revit.DB FilterIntegerRule
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FilterNumericValueRule type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from FilterRule ) |
![]() | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetEvaluator | Gets the evaluator that implements the test for this rule. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetEvaluator | Sets the evaluator that implements the test for this rule. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |