FailuresProcessingEventArgs Class


Failures Processing Event Args Class

The event arguments used by the FailuresProcessing event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FailuresProcessingEventArgs : RevitAPISingleEventArgs

The FailuresProcessingEventArgs type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method GetFailuresAccessor Provides access to the failure information in the document.
Public method GetProcessingResult Retrieves current status of the failures processing result.
Public method SetProcessingResult Sets the result of the failures processing accomplished during this event callback.
Top
Remarks

The event arguments provide access to the FailuresAccessor via GetFailuresAccessor which contains the details of the errors and/or warnings that caused the event to trigger.

The arguments also allow you to set a processing result via SetProcessingResult(FailureProcessingResult) . The processing result determines if Revit will attempt to recommit the currently failing transaction, roll it back, or continue. If you are explicitly dismissing warnings from the event callback, a processing result of Continue is sufficient. But if you are explicitly resolving errors from the event callback, you must change the processing result to ProceedWithCommit to ensure that the user is not shown the dismissed errors. If you wish to cancel the transaction silently without showing the errors to the user, set the processing result to ProceedWithRollback, however you must also call SetClearAfterRollback(Boolean) in order to dismiss the errors and silently cancel the transaction.

See Also