Ellipse Create |
Creates a new geometric ellipse or elliptical arc object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static Curve CreateCurve(
XYZ center,
double xRadius,
double yRadius,
XYZ xAxis,
XYZ yAxis,
double startParameter,
double endParameter
)
Parameters
- center XYZ
- The center.
- xRadius Double
- The x vector radius of the ellipse.
- yRadius Double
- The y vector radius of the ellipse.
- xAxis XYZ
- The x axis to define the ellipse plane. Must be normalized.
- yAxis XYZ
- The y axis to define the ellipse plane. Must be normalized.
- startParameter Double
- The raw parameter value at the start of the ellipse.
- endParameter Double
- The raw parameter value at the end of the ellipse.
Return Value
CurveThe new ellipse or elliptical arc.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was NULL |
ArgumentOutOfRangeException | The given value for xRadius must be greater than 0 and no more than 30000 feet. -or- The given value for yRadius must be greater than 0 and no more than 30000 feet. -or- xAxis is not length 1.0. -or- yAxis is not length 1.0. |
ArgumentsInconsistentException | The vectors xAxis and yAxis are not perpendicular. -or- Start parameter must be less than end parameter. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance). |

If the angle range is equal to or greater than 2 * PI, the curve will be automatically converted to an unbounded ellipse. If xRadius and yRadius are almost equal, the curve will be returned as an arc.