GetAllRebarShapeIds Method


Rebar Get All Rebar Shape Ids Method

Gets the ids of the RebarShapes elements that defines the shapes of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ElementId> GetAllRebarShapeIds()

Return Value

IList ElementId
Returns the ids of the RebarShapes elements that defines the shapes of the rebar.
Remarks
If multiple bars in the set has the same shape id, this id will be reported only one in the resulted array.
See Also