Family |
Constructs a new instance of a filter to match families by structural material type, with the option to match all families which are not of the given structural material type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FamilyStructuralMaterialTypeFilter(
StructuralMaterialType structuralMaterialType,
bool inverted
)
Parameters
- structuralMaterialType StructuralMaterialType
- The structural material type to match.
- inverted Boolean
- True if the filter should match all families which are not of the given structural material type.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |