Exporter |
Note: This API is now obsolete.
Obtains the IFC type associated to the given element for the current export.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

[ObsoleteAttribute("This function is deprecated in Revit 2025. Please use ExporterIFC.GetCategoryMappingTable instead.")]
public static string GetIFCType(
Element element,
ExporterIFC exporterIFC
)
Parameters
- element Element
- The element.
- exporterIFC ExporterIFC
- The exporter.
Return Value
StringThe IFC type. This is an empty string if the element should not be exported because it is not found in the mapping file.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

IFC type names are affected by the user's entries in the mapping file set for a given export operation.