Combo |
This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The ComboBox type exposes the following members.

Name | Description | |
---|---|---|
![]() | Current | Gets or sets the current checked ComboBox member of the ComboBox. |
![]() | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem ) |
![]() | Image | The image shown on the ComboBox. |
![]() | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem ) |
![]() | ItemType | Gets the item type. (Inherited from RibbonItem ) |
![]() | LongDescription | Long description of the command tooltip (Inherited from RibbonItem ) |
![]() | Name | The name of the item. (Inherited from RibbonItem ) |
![]() | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem ) |
![]() | ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem ) |
![]() | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem ) |

Name | Description | |
---|---|---|
![]() | AddItem | Adds a new item to the ComboBox. |
![]() | AddItems | Adds a new items to the ComboBox. |
![]() | AddSeparator | Adds a separator to the drop-down list. |
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Inherited from RibbonItem ) |
![]() | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetItems | Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Name | Description | |
---|---|---|
![]() | CurrentChanged | Subscribe to this event to be notified when the current item of the ComboBox is changed. |
![]() | DropDownClosed | Subscribe to this event to be notified when the drop-down of the ComboBox is closed. |
![]() | DropDownOpened | Subscribe to this event to be notified when the drop-down of the ComboBox is opened. |

The order of items shown in the ComboBox depends upon the order which they were added, unless the ComboBoxMembers have been assigned to groups. If the members have been assigned groups, they will be sorted to fall under their groups regardless of the order in which they were added. Use of this class is not supported in Revit Macros.