Combo |
This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The ComboBox type exposes the following members.

Name | Description | |
---|---|---|
![]() | Current | Gets or sets the current checked ComboBox member of the ComboBox. |
![]() | Image | The image shown on the ComboBox. |

Name | Description | |
---|---|---|
![]() | AddItem | Adds a new item to the ComboBox. |
![]() | AddItems | Adds a new items to the ComboBox. |
![]() | AddSeparator | Adds a separator to the drop-down list. |
![]() | GetItems | Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox. |

Name | Description | |
---|---|---|
![]() | CurrentChanged | Subscribe to this event to be notified when the current item of the ComboBox is changed. |
![]() | DropDownClosed | Subscribe to this event to be notified when the drop-down of the ComboBox is closed. |
![]() | DropDownOpened | Subscribe to this event to be notified when the drop-down of the ComboBox is opened. |

The order of items shown in the ComboBox depends upon the order which they were added, unless the ComboBoxMembers have been assigned to groups. If the members have been assigned groups, they will be sorted to fall under their groups regardless of the order in which they were added. Use of this class is not supported in Revit Macros.