Filled |
Creates a masking region on a sketch plane in a 3d model family.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FilledRegion CreateMaskingRegion(
Document document,
SketchPlane sketchPlane,
IList<CurveLoop> boundaries
)
Parameters
- document Document
- The family document in which to create the masking region.
- sketchPlane SketchPlane
- The sketch plane for use with the masking region.
- boundaries IList CurveLoop
- The masking region boundaries, which will be projected onto the sketch plane.
Return Value
FilledRegionThe new masking region.

Exception | Condition |
---|---|
ArgumentException | The document is not a 3d model family. -or- Filled regions can't be created in this document or view. -or- The sketch plane is not suitable for model elements. -or- The sketch plane normal is not parallel to the model's X, Y or Z axis. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the sketch plane; or input curves contain at least one helical curve. |
ArgumentNullException | A non-optional argument was null |

If the sketch plane is currently in use, then a copy of the sketch plane will be created and used. The sketch plane normal must be parallel to the model's X, Y or Z axis. The sketch plane can be a planar face reference to model geometry. The line style of the boundaries will be set to thin lines by default.