Split Method


Toposolid Split Method

Split the toposolid by the given curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ElementId> Split(
	IList<CurveLoop> splitCurveLoops
)

Parameters

splitCurveLoops IList CurveLoop
An array of planar curve loops that are used to split the toposolid. All of the curve loops should lie on the sketch plane of the toposolid.

Return Value

IList ElementId
An array of newly created toposolid ids after split.
Exceptions
Exception Condition
ArgumentException The split curve loops should all lie on the sketch plane of the toposolid.
ArgumentNullException A non-optional argument was null
See Also