HasValidDisplayPath Method


External Resource Reference Has Valid Display Path Method

Checks whether this external Resource has a valid display path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool HasValidDisplayPath()

Return Value

Boolean
True if the this external Resource has a valid display path. False otherwise.
Remarks
For an external resource, such as a Revit link loaded from an external server, the valid display path should be like "My Server://Nested/Nested_1.rvt". For an external resource, such as a Revit link loaded from the "built-in" server, the valid display path should be like "c:\LocalLinks\Link_1.rvt".
See Also