GetFaceReferences Method


Mass Surface Data Get Face References Method

Gets References to the faces that the MassSurfaceData provides properties for.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<Reference> GetFaceReferences()

Return Value

IList Reference
Returns an array of References to Faces that the MassSurfaceData provides properties for.
Remarks
The results are always references to Faces. The Reference Type should be REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE.
See Also