SymbolicCurveArray Class


Symbolic Curve Array Class

An array that contains model curves.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB SymbolicCurveArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SymbolicCurveArray : APIObject, 
	IEnumerable

The SymbolicCurveArray type exposes the following members.

Constructors
Name Description
Public method SymbolicCurveArray Initializes a new instance of the SymbolicCurveArray class
Top
Properties
Name Description
Public property IsEmpty Test to see if the array is empty.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Item Gets or sets a model curve at a specified index within the array.
Public property Size Returns the number of model curves that are in the array.
Top
Methods
Name Description
Public method Append Add the model curve to the end of the array.
Public method Clear Removes every model curve from the array, rendering it empty.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method ForwardIterator Retrieve a forward moving iterator to the array.
Public method GetEnumerator Retrieve a forward moving iterator to the array.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Insert Insert the specified model curve into the array.
Public method ReverseIterator Retrieve a backward moving iterator to the array.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also