Item Property


Binding Map Item Property

The get_Item method will get the binding item related to the input key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public override Binding this[
	Definition key
] { get; set; }

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Property Value

Binding
The returned value of get_Item is an InstanceBinding or TypeBinding object that contains the set of categories to which the parameter is bound. The input item is an InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
Remarks
set_Item is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown. Instead use Insert, Remove and ReInsert to modify the bindings in the document.
See Also