ReplaceReferenceTargets Method


Rebar Constraint Replace Reference Targets Method

Replaces the current set of references, the type of constraint and the offset value, with the newly provided ones. Will throw exception if this is a constraint for Shape Driven Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ReplaceReferenceTargets(
	RebarConstrainedHandle handle,
	IList<Reference> targetReferences,
	bool isConstraintToCover,
	double offsetValue
)

Parameters

handle RebarConstrainedHandle
The RebarConstrainedHandle that has this constraint.
targetReferences IList Reference
The references to which the rebar handle will be constrained. This collection must contain one or more references to faces of elements that can host rebar.
isConstraintToCover Boolean
If true the RebarConstraintType will be set to ToCover, otherwise RebarConstraintType will be set to FixedDistanceToHostFace.
offsetValue Double
The distance from references to the rebar handle.
Exceptions
Exception Condition
ArgumentException handle is no longer valid. -or- targetReferences is empty. -or- targetReferences do not represent faces from structurals that can host rebar.
ArgumentNullException A non-optional argument was null
InvalidOperationException Constrained rebar isn't a free form rebar element.
See Also