PostDocEventArgs Class


Post Doc Event Args Class

The class is used as base class for arguments of any post-event that is associated to a particular Document.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PostDocEventArgs : PostEventArgs

The PostDocEventArgs type exposes the following members.

Properties
Name Description
Public property Cancel Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
(Inherited from RevitEventArgs )
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitEventArgs )
Public property Document The document associated with the event.
Public property Status Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).
(Inherited from PostEventArgs )
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also