CreatePartList Method


Assembly View Utils Create Part List(Document, Element Id) Method

Creates a new part list multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ViewSchedule CreatePartList(
	Document document,
	ElementId assemblyInstanceId
)

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.

Return Value

ViewSchedule
A new part list multicategory schedule assembly view.
Exceptions
Exception Condition
ArgumentException assemblyInstanceId is not an AssemblyInstance.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
The new part list schedule will be preloaded with fields "Category", "Family and Type" and "Count". The document must be regenerated before using the schedule.
See Also