FieldDomainPointsByUV Class


Field Domain Points By UV Class

Represents a set of two-dimensional point coordinates (defined usually on surface)
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis FieldDomainPoints
Autodesk.Revit.DB.Analysis FieldDomainPointsByUV

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FieldDomainPointsByUV : FieldDomainPoints

The FieldDomainPointsByUV type exposes the following members.

Constructors
Name Description
Public method FieldDomainPointsByUV(IList UV ) Creates object from an array of two-dimensional point coordinates
Public method FieldDomainPointsByUV(IList UV , ICollection Double , ICollection Double ) Creates object from an array of two-dimensional point coordinates
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FieldDomainPoints )
Top
Methods
Name Description
Public method Dispose
(Inherited from FieldDomainPoints )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetGridCoordinates Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also