Parse Method


Element Id Parse Method

Parse the string representation of the id into a corresponding ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId Parse(
	string idStr
)

Parameters

idStr String
The string representation of the id to return.

Return Value

ElementId
ElementId string represented.
Exceptions
Exception Condition
InvalidOperationException Thrown when the string cannot be parsed into an ElementId.
Remarks
If the string represents [!:Autodesk::Revit::DB::Element::InvalidElementId] it will be returned.
See Also