ConvertCloudGUIDsToCloudPath Method (String, Guid, Guid)


Model Path Utils Convert Cloud GUIDs To Cloud Path Method

Converts a pair of cloud project and model GUIDs to a valid cloud path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ModelPath ConvertCloudGUIDsToCloudPath(
	string region,
	Guid projectGuid,
	Guid modelGuid
)

Parameters

region String
The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. Please see the reference values, like CloudRegionUS and CloudRegionEMEA , and the new regions from release note.
projectGuid Guid
The GUID of the cloud project which contains the model.
modelGuid Guid
The GUID of the Revit cloud model.

Return Value

ModelPath
The cloud model path.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
CentralModelException The cloud project is missing.
RevitServerCommunicationException The central server could not be reached.
RevitServerUnauthenticatedUserException You must sign in to Autodesk 360 in order to complete action.
RevitServerUnauthorizedException You are unauthorized to access this resource.
See Also