GetMultistoryStairsPlacementLevels Method


Railing Get Multistory Stairs Placement Levels Method

Gets the ids of the base levels of the stairs upon which this railing is placed.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ISet<ElementId> GetMultistoryStairsPlacementLevels()

Return Value

ISet ElementId
The ids of levels the railing is placed on. The returned set consists of a subset of the base level ids of the corresponding stairs in the MultistoryStairs .
Exceptions
Exception Condition
InvalidOperationException The railing is not hosted by stairs in MultistoryStairs .
Remarks
The method is valid only for railings hosted by stairs in MultistoryStairs .
See Also