GetReferenceName Method


Family Instance Get Reference Name Method

Gets the name of the reference plane in the family corresponding to the given family instance reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetReferenceName(
	Reference reference
)

Parameters

reference Reference
The family instance reference.

Return Value

String
Returns the name of the reference plane in the family corresponding to the given family instance reference. If the reference doesn't correspond to a named reference plane, returns an empty string.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If the given family reference corresponds to a named reference plane in the instance's family, the name of that reference plane will be returned. Otherwise, an empty string will be returned.
See Also