Document Class


Document Class

The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
Inheritance Hierarchy

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Document : ItemFactoryBase

The Document type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method NewArea Creates a new area
Public method Code example NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Creates a new Area BoundaryConditions element on a host element.
Public method Code example NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Creates a new Area BoundaryConditions element on a reference.
Public method NewAreaBoundaryLine Creates a new boundary line as an Area border.
Public method NewAreas Creates new areas
Public method NewAreaTag Creates a new area tag.
Public method NewCrossFitting Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
Public method NewCurtainSystem Creates a new CurtainSystem element from a set of faces.
Public method NewCurtainSystem2 Creates a new CurtainSystem element from a set of face references.
Public method NewElbowFitting Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
Public method NewExtrusionRoof Creates a new Extrusion Roof.
Public method Code example NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
Public method Code example NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
Public method NewFascia(FasciaType, Reference) Creates a fascia along a reference.
Public method NewFascia(FasciaType, ReferenceArray) Creates a fascia along a reference array.
Public method NewFlexDuct(IList XYZ , FlexDuctType) Adds a new flexible duct into the document, using a point array and duct type.
Public method NewFlexDuct(Connector, Connector, FlexDuctType) Adds a new flexible duct into the document, using two connector, and duct type.
Public method NewFlexDuct(Connector, IList XYZ , FlexDuctType) Adds a new flexible duct into the document, using a connector, point array and duct type.
Public method NewFlexPipe(IList XYZ , FlexPipeType) Adds a new flexible pipe into the document, using a point array and pipe type.
Public method NewFlexPipe(Connector, Connector, FlexPipeType) Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method NewFlexPipe(Connector, IList XYZ , FlexPipeType) Adds a new flexible pipe into the document, using a connector, point array and pipe type.
Public method Code example NewFootPrintRoof Creates a new FootPrintRoof element.
Public method NewGutter(GutterType, Reference) Creates a gutter along a reference.
Public method NewGutter(GutterType, ReferenceArray) Creates a gutter along a reference array.
Public method Code example NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Creates a new Line BoundaryConditions element on a host element.
Public method Code example NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Creates a new Line BoundaryConditions element on a reference.
Public method Code example NewMechanicalSystem Creates a new MEP mechanical system element.
Public method NewOpening(Element, CurveArray, eRefFace) Creates a new opening in a beam, brace and column.
Public method NewOpening(Element, CurveArray, Boolean) Creates a new opening in a roof, floor and ceiling.
Public method NewOpening(Level, Level, CurveArray) Creates a new shaft opening between a set of levels.
Public method NewOpening(Wall, XYZ, XYZ) Creates a rectangular opening on a wall.
Public method NewPipingSystem Creates a new MEP piping system element.
Public method Code example NewPointBoundaryConditions Creates a new Point BoundaryConditions Element.
Public method NewRoom(Phase) Creates a new unplaced room and with an assigned phase.
Public method Code example NewRoom(Level, UV) Creates a new room on a level at a specified point.
Public method Code example NewRoom(Room, PlanCircuit) Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
Public method NewRoomBoundaryLines Creates a new boundary line as an Room border.
Public method NewRooms2(Level) Creates new rooms in each plan circuit found in the given level in the last phase.
Public method NewRooms2(Level, Phase) Creates new rooms in each plan circuit found in the given level in the given phase.
Public method NewRooms2(Phase, Int32) Creates new unplaced rooms in the given phase.
Public method Code example NewRoomTag Creates a new RoomTag referencing a room in the host model or in a Revit link.
Public method NewSlabEdge(SlabEdgeType, Reference) Creates a slab edge along a reference.
Public method NewSlabEdge(SlabEdgeType, ReferenceArray) Creates a slab edge along a reference array.
Public method NewSpace(Phase) Creates a new unplaced space on a given phase.
Public method NewSpace(Level, UV) Creates a new space element on the given level at the given location.
Public method NewSpace(Level, Phase, UV) Creates a new space element on the given level, at the given location, and assigned to the given phase.
Public method NewSpaceBoundaryLines Creates a new boundary line as an Space border.
Public method NewSpaces2(Phase, Int32) Creates a set of new unplaced spaces on a given phase.
Public method NewSpaces2(Level, Phase, View) Creates new spaces on the available plan circuits of a the given level.
Public method NewSpaceTag Creates a new SpaceTag.
Public method NewSpotCoordinate Generate a new spot coordinate object within the project.
Public method NewSpotElevation Generate a new spot elevation object within the project.
Public method NewTakeoffFitting Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
Public method NewTeeFitting Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
Public method NewTransitionFitting Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
Public method NewUnionFitting Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
Public method NewZone Creates a new Zone element.
Top
Remarks
The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly.
See Also