FieldValues Constructor (IList(ValueAtPoint), XYZ)


Field Values(IList Value At Point , XYZ) Constructor

Creates object from an array of domain point values

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FieldValues(
	IList<ValueAtPoint> valueAtPoint,
	XYZ unitDirection
)

Parameters

valueAtPoint IList ValueAtPoint
Array of values, each corresponding to a domain point
unitDirection XYZ
Unit vector that gives the same direction for values (for diagrams)
Exceptions
Exception Condition
ArgumentException Members of valueAtPoint contain different numbers of measurements -or- unitDirection is not a unit vector
ArgumentNullException A non-optional argument was null
See Also