SetMemberIds Method


Assembly Instance Set Member Ids Method

Sets member element ids for the assembly instance. All existing members are cleared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMemberIds(
	ICollection<ElementId> memberIds
)

Parameters

memberIds ICollection ElementId
Element ids to set for the assembly instance.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ForbiddenForDynamicUpdateException This method may not be called during dynamic update.
See Also