ISingleServerService Interface


ISingle Server Service Interface

The base interface class for all single-server services.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface ISingleServerService : IExternalService

The ISingleServerService type exposes the following members.

Methods
Name Description
Public method Execute Implement this method to execute the given server.
(Inherited from IExternalService )
Public method GetDescription Implement this method to return a description of the service.
(Inherited from IExternalService )
Public method GetName Implement this method to return the name of the service.
(Inherited from IExternalService )
Public method GetServiceId Implement this method to return the unique Id of the service.
(Inherited from IExternalService )
Public method GetVendorId Implement this method to return the vendor Id of the service.
(Inherited from IExternalService )
Public method IsValidServer Implement this method to check if the given instance represents a valid server of this service.
(Inherited from IExternalService )
Public method OnServersChanged Implement this method to handle situations when servers for the service have changed.
(Inherited from IExternalService )
Public method OnServersDisparity Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.
(Inherited from IExternalService )
Top
Remarks

Both single-server and multi-server services may have more than one server registered for them. The difference between these two kinds is while there can only be one active server at any given time for a single-sever service, there may be a set of active servers assigned for a multi-server service.

ISingleServerService does not have any specific methods (currently) added to those inherited from the common IExternalService interface.
See Also