IExternal |
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The IExternalResourceUIServer type exposes the following members.

Name | Description | |
---|---|---|
![]() | GetDBServerId | Implement this method to return the id of the server which is associated with this UI server. |
![]() | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer ) |
![]() | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer ) |
![]() | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer ) |
![]() | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer ) |
![]() | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer ) |
![]() | HandleBrowseResult | Implement this method to handle results from browsing external resources in the UI. It is recommended that the server only respond in the case of a critical error. |
![]() | HandleLoadResourceResults | Implement this method to display any UI related to messages or errors that result when the DB server associated with this UI server attempts to load an external resource. |

IExternalResourceUIServer is the UI server associated with IExternalResourceServer. IExternalResourceServer provides an interface for loading an external resource (such as a Revit link or the keynote data) from a source outside of Revit. IExternalResourceUIServer provides an interface for displaying the results of such an operation to the Revit user.
IExternalResourceUIServers must be associated with an IExternalResourceServer in order to display any UI. Implement GetDBServerId to declare a relationship between an IExternalResourceUIServer and an IExternalResourceServer.
The primary method in IExternalResourceUIServer is [M:Autodesk.Revit.UI.IExternalResourceUIServer.HandleLoadResourceResults(Autodesk.Revit.DB.Document,System.Collections.Generic.IList`1{Autodesk.Revit.DB.ExternalResourceLoadData})] . After an IExternalResourceServer loads an external resource, Revit will call HandleLoadResourceResults() on the IExternalResourceUIServer, so that it may display any related UI. Revit will provide an ExternalResourceLoadData to the UI server, which will contain information about the resource which was loaded, information about the context of the load operation, and any Revit-side errors.
The ExternalResourceLoadData passed to HandleLoadResourceResults will also contain a GUID to uniquely identify the load request. This identifier can help IExternalResourceUIServers query their IExternalResourceServers for additional information about errors that occurred during specific load operations. Particularly, the IExternalResourceUIServer may wish to ask the IExternalResourceServer about errors which Revit is not aware of. For example, if the IExternalResourceServer includes a website and the user is not logged in, Revit will not have any information about this error.