Create Method (Document, String, ICollection(ElementId))


Parameter Filter Element Create(Document, String, ICollection Element Id ) Method

Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ParameterFilterElement Create(
	Document aDocument,
	string name,
	ICollection<ElementId> categories
)

Parameters

aDocument Document
The document in which to create the ParameterFilterElement.
name String
The user-visible name for the new ParameterFilterElement.
categories ICollection ElementId
The categories for the new ParameterFilterElement.

Return Value

ParameterFilterElement
A pointer to the new ParameterFilterElement.
Exceptions
Exception Condition
ArgumentException name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name.
ArgumentNullException A non-optional argument was null
See Also