PDFExport |
Whether naming rule is valid or not.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsValidNamingRule(
IList<TableCellCombinedParameterData> namingRule
)
Parameters
- namingRule IList TableCellCombinedParameterData
- The naming rule to be validated.
Return Value
BooleanWhether or not the name is valid.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

If true, this naming rule is a valid. If false, this naming rule is not valid for empty naming rule or illegal characters, such as .
C#
\ / : * ? " < > |