Location |
Provides the ability to get and set the curve of a curve based element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


This property can be used to set the location of curve based element to any desired position. Many elements are curve based. Some examples are walls, beams and braces.

void MoveUsingCurveParam(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
LocationCurve wallLine = wall.Location as LocationCurve;
XYZ p1 = XYZ.Zero;
XYZ p2 = new XYZ(10, 20, 0);
Line newWallLine = Line.CreateBound(p1, p2);
// Change the wall line to a new line.
wallLine.Curve = newWallLine;
}