ElementFilterIsAcceptableForParameterFilterElement Method (ElementFilter)


Parameter Filter Element Element Filter Is Acceptable For Parameter Filter Element(Element Filter) Method

Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool ElementFilterIsAcceptableForParameterFilterElement(
	ElementFilter elementFilter
)

Parameters

elementFilter ElementFilter
The ElementFilter to validate.

Return Value

Boolean
True if the ElementFilter is acceptable for use by an ParameterFilterElement, false if not.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter representing a Boolean combination of ElementParameterFilters. In addition, we check that each ElementParameterFilter satisfies the following conditions: Its array of FilterRules is not empty and contains:
  • Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
  • Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
  • Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Note that cases in the second and third bullet are currently allowed only if the parent node of ElementParameterFilter is LogicalOrFilter.
See Also