CustomInitialColor Class


Custom Initial Color Class

This class encapsulates a custom initial lighting color.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting InitialColor
Autodesk.Revit.DB.Lighting CustomInitialColor

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CustomInitialColor : InitialColor

The CustomInitialColor type exposes the following members.

Constructors
Name Description
Public method CustomInitialColor(CustomInitialColor) Creates a copy of the given custom initial color
Public method CustomInitialColor(Double) Creates a custom initial color set to the given color
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from InitialColor )
Public property Temperature The custom color temperature value.
Public property TemperatureValue The light color temperature value in Kelvins.
(Inherited from InitialColor )
Top
Methods
Name Description
Public method Clone Creates a copy of the InitialColor derived object.
(Inherited from InitialColor )
Public method Dispose
(Inherited from InitialColor )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This color is called an initial color because a color filter can also be added to modify the color.
See Also