CustomInitialColor Class


Custom Initial Color Class

This class encapsulates a custom initial lighting color.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting InitialColor
Autodesk.Revit.DB.Lighting CustomInitialColor

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CustomInitialColor : InitialColor

The CustomInitialColor type exposes the following members.

Constructors
Name Description
Public method CustomInitialColor(CustomInitialColor) Creates a copy of the given custom initial color
Public method CustomInitialColor(Double) Creates a custom initial color set to the given color
Top
Properties
Name Description
Public property Temperature The custom color temperature value.
Top
Methods
Name Description
Top
Remarks
This color is called an initial color because a color filter can also be added to modify the color.
See Also