Routing |
Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public ElementId GetMEPPartId(
RoutingPreferenceRuleGroupType groupType,
RoutingConditions conditions
)
Parameters
- groupType RoutingPreferenceRuleGroupType
- The routing preference group
- conditions RoutingConditions
- A set of routing conditions
Return Value
ElementIdThe Id of the fitting or segment that met the given routing conditions.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |