DirectShapeRoomBoundingOption Enumeration


Direct Shape Room Bounding Option Enumeration

An enumerated type containing possible room bounding settings for DirectShapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum DirectShapeRoomBoundingOption
Members
Member name Value Description
NotApplicable 0 The associated DirectShape doesn't have a room bounding parameter, and isn't allowed to. Trying to change to this value will result in an exception. Trying to change from this value is restricted to DirectShapes that can be room bounding.
SetByParameter 1 The associated DirectShape has a room bounding parameter which is which is writeable and defaults to on. If can be toggled by a user or the API (by accessing the parameter WALL_ATTR_ROOM_BOUNDING).
See Also