Element |
A filter wrapping a set of elements.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementIdSetFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementIdSetFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElementIdSetFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementIdSetFilter | Constructs a new instance of a filter wrapping a set of elements. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetIdsToInclude | Returns the ids of this filter. |

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.