SetPlainText Method (String)


Formatted Text Set Plain Text(String) Method

Sets the entire text with the given text in a plain text form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetPlainText(
	string plainText
)

Parameters

plainText String
The given text in a plain text form.
Exceptions
Exception Condition
ArgumentException plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- plainText contains invalid characters such as a newline character.
ArgumentNullException A non-optional argument was null
Remarks
Any individual formatting present before will be lost after applying this function and the text will have uniform formatting. If the text does not end with a carriage return character ('\r') one will be added. An empty string is allowed. The given text should have no more than 30,000 characters, not counting a terminating carriage return character ('\r'). Newline characters ('\n') are not allowed.
See Also