FilterNumericGreater Class


Filter Numeric Greater Class

Tests whether numeric values from the document are greater than a certain value
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterNumericGreater : FilterNumericRuleEvaluator

The FilterNumericGreater type exposes the following members.

Constructors
Name Description
Public method FilterNumericGreater Constructs an instance of FilterNumericGreater.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterNumericRuleEvaluator )
Top
Methods
Name Description
Public method Dispose
(Inherited from FilterNumericRuleEvaluator )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Evaluate(Int32, Int32) Obsolete.
Derived classes should override this method to implement the desired test.
(Inherited from FilterNumericRuleEvaluator )
Public method Evaluate(Int64, Int64) Derived classes should override this method to implement the desired test.
(Inherited from FilterNumericRuleEvaluator )
Public method Evaluate(Double, Double, Double) Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.
(Inherited from FilterNumericRuleEvaluator )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also