Site |
Note: This API is now obsolete.
Creates a new SiteSubRegion element and adds it to the document.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

[ObsoleteAttribute("This method is deprecated in Revit 2024 with the introduction of the new Toposolid elements. It is recommended that Toposolid elements should be used in place of TopographySurface elements.")]
public static SiteSubRegion Create(
Document document,
IList<CurveLoop> curveLoops
)
Parameters
- document Document
- The document to be modified.
- curveLoops IList CurveLoop
- The boundary of the subregion.
Return Value
SiteSubRegionThe new SubRegion surface.

Exception | Condition |
---|---|
ArgumentException | The input curve loops cannot compose a valid boundary, that means: no curve loop is contained in the given collection; these curve loops intersect with each other for some of them; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Failed to create the Sketch for the boundary of the current Subregion. -or- Cannot find an appropriate host TopographySurface for the Subregion. -or- The given curve loops intersect with curve loops of existing SiteSubRegions hosted on the same TopographySurface. -or- The boundary of SubRegion is entirely inside or overlaps at least one existing BuildingPad hosted on the same TopographySurface. This behavior is not allowed. |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

This will create a new TopographySurface element which represents a subregion. If you need access to this Element you can obtain it from TopographySurface .