ExportFontTable Class


Export Font Table Class

A table supporting a mapping of Revit font names to font names that will be set in the target export format.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportFontTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportFontTable : IEnumerable<KeyValuePair<ExportFontKey, ExportFontInfo>>, 
	IDisposable

The ExportFontTable type exposes the following members.

Constructors
Name Description
Public method ExportFontTable Constructs a new ExportFontTable with default values.
Top
Properties
Name Description
Public property Count Count of the items contained in the collection.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Item A copy of the ExportFontInfo for the font's ExportFontKey .
Top
Methods
Name Description
Public method Add Inserts a (key,info) pair into Export font table.
Public method Clear Removes all contents stored in the table.
Public method ContainsKey Checks whether a font key exists in the table.
Public method Dispose Releases all resources used by the ExportFontTable
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetExportFontInfo Gets a copy of the font info associated to the input font key.
Public method GetFontTableIterator Returns a FontTableIterator that iterates through the collection.
Public method GetKeys Returns a collection of the keys stored in this table.
Public method GetValues Returns a collection of the values stored in this table.
Public method Remove Removes the pair (key, info) by font key.
Top
Remarks

This table is structured as a mapping from ExportFontKey to ExportFontInfo members. The ExportFontKey contains the identification information for the font table: the Revit font name. The ExportFontInfo contains the font name to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportFontInfo returned will be a copy of the ExportFontInfo from the table. In order to make changes to the ExportFontInfo and use those settings during export, set the modified ExportFontInfo back into the table using the same key.

See Also