GetSpliceChain Method


Rebar Splice Utils Get Splice Chain Method

Returns all the rebars that are part of a splice chain with the input rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ElementId> GetSpliceChain(
	Rebar rebar
)

Parameters

rebar Rebar
The input rebar.

Return Value

IList ElementId
The splice chain.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The elements in the output list are in exactly the same order that they are constrained to each other. The first element in the array is the one whose Rebar Plane, Out of Plane Extent and Edge are not constrained to a rebar from the chain (second is constrained to first, third to second and so on). The output list will also contain the input rebar id. If the rebar is not in a splice chain the returned list will contain just one element which is the id of the input rebar.
See Also