CreateSimpleCompoundStructure Method


Compound Structure Create Simple Compound Structure Method

Creates a non-vertically compound structure comprised of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static CompoundStructure CreateSimpleCompoundStructure(
	IList<CompoundStructureLayer> layers
)

Parameters

layers IList CompoundStructureLayer
An array which describes the parallel layers of this compound structure.

Return Value

CompoundStructure
A newly created compound structure.
Exceptions
Exception Condition
ArgumentException One or more layers is not valid.
ArgumentNullException A non-optional argument was null
Remarks
All layers are in the core, i.e. there are no shell layers created.
See Also