Rebar |
A constraint that can be applied to a RebarShapeDefinitionByArc and drives the straight distance between the arc endpoints.

System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintChordLength
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintChordLength
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarShapeConstraintChordLength type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarShapeConstraintChordLength | Create a constraint to drive chord length. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RebarShapeConstraint ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RebarShapeConstraint ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |