FabricationRodInfo Class


Fabrication Rod Info Class

The rod information of the fabrication part.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FabricationRodInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationRodInfo : IDisposable

The FabricationRodInfo type exposes the following members.

Properties
Name Description
Public property CanRodsBeHosted Controls whether the hanger's rod's will be automatically hosted by other elements.
Public property IsAttachedToStructure Checks if the hanger is attached to structure.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property RodCount Gets the number of rods.
Top
Methods
Name Description
Public method AttachToHanger Attaches the hanger rod to another bearer hanger.
Public method AttachToStructure Attaches to the nearest structural element.
Public method Dispose Releases all resources used by the FabricationRodInfo
Public method GetBearerExtension Gets the bearer extension. The method is applicable only for bearer hanger.
Public method GetRodAttachedElementId Gets the identifier of the attached component for the specified rod.
Public method GetRodEndPosition Gets the position of the rod end.
Public method GetRodLength Get the current rod length. If the rod is the length will include structural extension.
Public method GetRodStructureExtension Gets the length of the rod's top extension into structure.
Public method IsRodLockedWithHost Checks if the rod is locked with the host. The method is applicable only for bearer hanger.
Public method SetBearerExtension Sets the bearer extension. The method is applicable only for bearer hanger.
Public method SetRodEndPosition Sets the position of the rod end. The method is applicable only for bearer hanger.
Public method SetRodLength Set the rod length of the hanger for the specified rod index, excluding top extension. The hanger must not be set to be auto-hosted.
Public method SetRodLockedWithHost Locks the rod with the host. The method is applicable only for bearer hanger.
Public method SetRodStructureExtension Set the length of the rod's top extension into structure. The rod must be attached to structure.
Top
Remarks
A fabrication part may have one or more rods. The FabricationRodInfo stores the rod information of the fabrication part.
See Also