BuiltInFailures.TrussFailures Class


Built In Failures Truss Failures Class

Failures about Truss.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures TrussFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class TrussFailures

The BuiltInFailures TrussFailures type exposes the following members.

Properties
Name Description
Public property Static member IncorrectWallUsageWithAttachedStruct A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
Public property Static member InvalidWorkplaneForStructuralFraming Workplane not valid for Structural Framing component "[Family Name]"
Public property Static member RemoveTrussSketch Remove Sketch
Public property Static member TrussBadTransformation Revit cannot transform the truss Layout Family to the Truss as oriented in the project.
Public property Static member TrussChordUntransformable Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
Public property Static member TrussDuplicateEngineeringType Elements have duplicate 'Engineering Type' values.
Public property Static member TrussInvalidSymbolGeom Truss is unable to generate any members due to layout family error.
Public property Static member TrussIsAttachedTo Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.
Public property Static member TrussLayoutNonSympleTopChord This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
Public property Static member TrussLayoutOverlapedCurves The current transformation of this specific truss layout will some sub members to overlap.
Public property Static member TrussNotJoinedWebs The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
Public property Static member TrussUserDefinedMemberDeleted A user-defined structural member was deleted due to missing or deleted references.
Public property Static member TrussUserDefinedMemberNotJoined Both start and end of web must intersect the truss.
Top
See Also