Unit |
Converts a value from a given unit to Revit's internal units.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- value Double
- The value to convert.
- unitTypeId ForgeTypeId
- Identifier of the unit quantifying the value.
Return Value
DoubleThe converted value.

Exception | Condition |
---|---|
ArgumentException | The given value for value is not finite -or- unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). |
ArgumentNullException | A non-optional argument was null |