IMemberForcesServer Interface


IMember Forces Server Interface

Interface for the Member Forces server to implement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IMemberForcesServer : IExternalServer

The IMemberForcesServer type exposes the following members.

Methods
Name Description
Public method GetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer )
Public method GetName Implement this method to return the name of the server.
(Inherited from IExternalServer )
Public method GetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer )
Public method GetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer )
Public method GetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer )
Public method MemberForcesUpdate The server's method that will be called when Revit User clicks Member Forces button in the MPP.
Top
See Also