PickBoxStyle Enumeration


Pick Box Style Enumeration

The enum that controls the style of the pick box.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum PickBoxStyle
Members
Member name Value Description
Crossing 0 Draws the box with the style that is used when selecting objects completely or partially inside the box.
Enclosing 1 Draws the box with the style that is used when selecting objects that are completely enclosed by the box.
Directional 2 The style of the box depends on the direction in which the box is being drawn. It uses the Crossing style if it is being drawn from right to left, or the Enclosing style when drawn in the opposite direction.
See Also