Failure |
The unique identifier of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FailureDefinitionId type exposes the following members.

Name | Description | |
---|---|---|
![]() | FailureDefinitionId | Creates a new FailureDefinitionId instance. |


Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() ![]() | Equality(FailureDefinitionId, FailureDefinitionId) | Compares two FailureDefinitionId instances. |
![]() ![]() | Inequality(FailureDefinitionId, FailureDefinitionId) | Compares two FailureDefinitionId instances. |

Each possible failure in Revit must be defined and registered during Revit application startup by creating a FailureDefinition object. Unique FailureDefinitionId must be used as a key to register FailureDefinition. Those unique FailureDefinitionId should be created using GUID generation tool. Later FailureDefinitionId can be used to lookup FailureDefinition in FailureDefinitionRegistry, and create and post FailureMessages.