RemoveMemberIds Method


Assembly Instance Remove Member Ids Method

Removes member element ids from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RemoveMemberIds(
	ICollection<ElementId> memberIds
)

Parameters

memberIds ICollection ElementId
Element ids to be removed from the assembly instance.
Exceptions
Exception Condition
ArgumentException One or more element ids was not permitted to be removed from the assembly instance. Provided set should not be empty and all elements should be a member of the assembly instance. -or- The provided set includes one or more element ids that cannot be added to or removed from the assembly on their own.
ArgumentNullException A non-optional argument was null
See Also