IsParameterApplicable Method


Parameter Filter Utilities Is Parameter Applicable Method

Used to determine whether the element supports the given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsParameterApplicable(
	Element element,
	ElementId parameter
)

Parameters

element Element
The element to query for support of the given parameter.
parameter ElementId
The parameter for which to query support.

Return Value

Boolean
True if the element supports the given parameter, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This operation is supported for external (e.g., shared, project) parameters only.
See Also