ExternalDataInstanceAddedIntoDocumentEventArgs Class


External Data Instance Added Into Document Event Args Class

The event arguments used by the ExternalDataInstanceAddedInto event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalDataInstanceAddedIntoDocumentEventArgs : RevitAPIPostDocEventArgs

The ExternalDataInstanceAddedIntoDocumentEventArgs type exposes the following members.

Properties
Name Description
Public property ItemId The id of the external data item to which a new reference has been added.
Public property NewInstanceId The newly added external data instance id.
Public property ProjectId The id of the external project of the external data item to which a new reference has been added.
Public property TypeId The type id of the newly added external data instance id.
Top
Methods
Name Description
Top
See Also